Manuel Lupotto

Referente (dormiente)

Studente di biologia all'università di Pavia, classe 1986, segue soprattutto i progetti di tipo medico.

Collabora al portale curando la documentazione e le traduzioni legate ai progetti di tipo medico. Scrive articoli sulle novità di Rosetta@home ed altri progetti correlati (RALPH, fold.it).

E' presente nel forum di discussione dove partecipa alle iniziative della community.

 

Inviato: 21/01/2015 18:58 da Gattorantolo #112707
Avatar di Gattorantolo
Incrociamo le dita…. :sperem:
Inviato: 20/01/2015 15:12 da boboviz #112678
Avatar di boboviz
Effinalmente!!!

I've just shut down the Test Server completely.
After checking the results of the last 10 days, we came to the decision to release this version.
There are still sporadic problems when running multiple jobs on a single AMD GPU, but the failures are reliably detected by our checks, and occur almost immediately after starting the workunit. If they occur once, they always occur on a host, therefore we believe it is a specific driver / GPU combination causing this.
We will keep investigating this bug, but don't see a reason to hold back the release now.
If you run into this problem, please change your app_config to allow only a single job per GPU.


Probabilmente questa versione entrerà in produzione tra alcuni giorni, finita la coda di wu presenti sul server di produzione.
Inviato: 19/01/2015 19:40 da Gattorantolo #112630
Avatar di Gattorantolo
boboviz ha scritto:

boboviz ha scritto:

Non capisco perchè aspettino a passarla in produzione.


Oggi son 2 mesi di test......
:rotoli:

Se poi non funzionerà ancora sulle Nvidia mi sentirete bestemmiare in afro-cubano... :asd:
Inviato: 19/01/2015 16:37 da boboviz #112612
Avatar di boboviz
boboviz ha scritto:

Non capisco perchè aspettino a passarla in produzione.


Oggi son 2 mesi di test......
:rotoli:
Inviato: 14/01/2015 22:31 da boboviz #112431
Avatar di boboviz
Gattorantolo ha scritto:

Ad ogni modo le WU test vanno a bomba, 98 % di carico GPU... ;)


Tra l'altro, con l'ultima versione, molti problemi si sono risolti
Non capisco perchè aspettino a passarla in produzione.
Inviato: 14/01/2015 13:52 da Gattorantolo #112420
Avatar di Gattorantolo
boboviz ha scritto:

Gattorantolo ha scritto:

Ma le statistiche di questo progetto dove sono? Non sono mica aggiornate... :mad:


Dal sito di Poem:

We appreciate every help for testing, but please keep the following in mind:
- Test server results will not be used for scientific publications.
- Credits will not be listed in the BOINC cross-project statistics.
- Test server applications may crash your system, so be sure to save any valuable data beforehand.
Best practice is to return a few tasks, and immediately detach from the POEM@TEST project.

:sob: :sob: :sob:
Ad ogni modo le WU test vanno a bomba, 98 % di carico GPU... ;)
Inviato: 14/01/2015 09:23 da astroale #112409
Avatar di astroale
boboviz ha scritto:

Gattorantolo ha scritto:

Ma le statistiche di questo progetto dove sono? Non sono mica aggiornate... :mad:


Dal sito di Poem:

We appreciate every help for testing, but please keep the following in mind:
- Test server results will not be used for scientific publications.
- Credits will not be listed in the BOINC cross-project statistics.
- Test server applications may crash your system, so be sure to save any valuable data beforehand.
Best practice is to return a few tasks, and immediately detach from the POEM@TEST project.


BTW tutte le volte che ho elaborato per il progetto di test poi dopo qualche tempo mi sono trovato dei crediti su quello principale, come se li avessero trasferiti tra i due server.
Inviato: 14/01/2015 08:37 da boboviz #112407
Avatar di boboviz
Gattorantolo ha scritto:

Ma le statistiche di questo progetto dove sono? Non sono mica aggiornate... :mad:


Dal sito di Poem:

We appreciate every help for testing, but please keep the following in mind:
- Test server results will not be used for scientific publications.
- Credits will not be listed in the BOINC cross-project statistics.
- Test server applications may crash your system, so be sure to save any valuable data beforehand.
Best practice is to return a few tasks, and immediately detach from the POEM@TEST project.

Inviato: 14/01/2015 05:24 da Gattorantolo #112405
Avatar di Gattorantolo
Ma le statistiche di questo progetto dove sono? Non sono mica aggiornate... :mad:
Inviato: 13/01/2015 19:57 da Gattorantolo #112398
Avatar di Gattorantolo
Mi sono agganciato pure io…e guarda guarda, 4 GPU e 4 WU all`opera… non ci credo :applauso:
Pure la % di carico delle GPU è notevole, praticamente non scendono mai sotto il 95% :eek: :king:
…speriamo sarà così pure sul Poem produttivo... ;)
Inviato: 11/01/2015 10:47 da Rick! #112313
Avatar di Rick!
sabayonino ha scritto:

Rick! ha scritto:

boboviz ha scritto:

sabayonino ha scritto:

non insistere ... non mi porterai mai dalla parte della forza oscura (o sforzo intestinale :fuck: )

:starwars:


:asd:

Comunque:

If some of you have the time it would also be very helpful for us to randomly pause and resume jobs which are running on the same gpu concurrently. That was one way to trigger the bug. If you could do this, it would help us to be sure we have a fix in place.

Bobo riesci a dirmi in quale forum e quale thread c'è questa richiesta?
Tutto ok per me, ma non riesco a capire dove postare :(


boinc.fzk.de/poem/forum_thread.php?id=1097

Grazie Saba
Inviato: 11/01/2015 10:02 da sabayonino #112312
Avatar di sabayonino
Rick! ha scritto:

boboviz ha scritto:

sabayonino ha scritto:

non insistere ... non mi porterai mai dalla parte della forza oscura (o sforzo intestinale :fuck: )

:starwars:


:asd:

Comunque:

If some of you have the time it would also be very helpful for us to randomly pause and resume jobs which are running on the same gpu concurrently. That was one way to trigger the bug. If you could do this, it would help us to be sure we have a fix in place.

Bobo riesci a dirmi in quale forum e quale thread c'è questa richiesta?
Tutto ok per me, ma non riesco a capire dove postare :(


boinc.fzk.de/poem/forum_thread.php?id=1097
Inviato: 11/01/2015 09:54 da Rick! #112310
Avatar di Rick!
boboviz ha scritto:

sabayonino ha scritto:

non insistere ... non mi porterai mai dalla parte della forza oscura (o sforzo intestinale :fuck: )

:starwars:


:asd:

Comunque:

If some of you have the time it would also be very helpful for us to randomly pause and resume jobs which are running on the same gpu concurrently. That was one way to trigger the bug. If you could do this, it would help us to be sure we have a fix in place.

Bobo riesci a dirmi in quale forum e quale thread c'è questa richiesta?
Tutto ok per me, ma non riesco a capire dove postare :(
Inviato: 09/01/2015 12:44 da boboviz #112257
Avatar di boboviz
sabayonino ha scritto:

non insistere ... non mi porterai mai dalla parte della forza oscura (o sforzo intestinale :fuck: )

:starwars:


:asd:

Comunque:

If some of you have the time it would also be very helpful for us to randomly pause and resume jobs which are running on the same gpu concurrently. That was one way to trigger the bug. If you could do this, it would help us to be sure we have a fix in place.

Inviato: 08/01/2015 21:22 da sabayonino #112249
Avatar di sabayonino
boboviz ha scritto:

sabayonino ha scritto:

anche se mi sembra che la seconda WU di ogi GPU sia un pelino più lenta della sua controparte...probbilmente non c'è un ottimo balance tra le risorse... m è sepre un buon risultato :asd:


Pure sulla mia gpu una wu va più veloce dell'altra.
Non so se sia legato al fatto che la mia gpu è una mezza pippa o se è il codice.
Sarebbe da vedere come funziona in schede gcn come una R9 290.


non insistere ... non mi porterai mai dalla parte della forza oscura (o sforzo intestinale :fuck: )

:starwars:
Inviato: 08/01/2015 21:18 da boboviz #112248
Avatar di boboviz
sabayonino ha scritto:

anche se mi sembra che la seconda WU di ogi GPU sia un pelino più lenta della sua controparte...probbilmente non c'è un ottimo balance tra le risorse... m è sepre un buon risultato :asd:


Pure sulla mia gpu una wu va più veloce dell'altra.
Non so se sia legato al fatto che la mia gpu è una mezza pippa o se è il codice.
Sarebbe da vedere come funziona in schede gcn come una R9 290.
Inviato: 08/01/2015 19:47 da sabayonino #112247
Avatar di sabayonino
boboviz ha scritto:

E' uscita, sul sito di test, sia la versione nuova per cpu che per gpu (la 2.16)
Gli admin chiedono:

We'd especially like to test parallel runs of the GPU application. If you configured your client to run multiple jobs on a single card, or if you have multiple GPUs, we'd highly appreciate your participation.


Saba, Gatto, dove siete??

POEM@TEST	2.16 POEM++ OpenCL version (opencl_nvidia_101)	poempp_1vii_1420715294_1456639931_0	00:00:50 (00:00:43)	9,0	06:28:30	0,5C + 0,5NV (d0)	Running	Gentoo-10	

POEM@TEST	2.16 POEM++ OpenCL version (opencl_nvidia_101)	poempp_1vii_1420715322_2035245692_0	00:00:33 (00:00:25)	5,0	06:30:56	0,5C + 0,5NV (d1)	Running	Gentoo-10	

POEM@TEST	2.16 POEM++ OpenCL version (opencl_nvidia_101)	poempp_2k39_1420715367_1006982763_0	00:00:50 (00:00:38)	4,0	06:31:00	0,5C + 0,5NV (d0)	Running	Gentoo-10	

POEM@TEST	2.16 POEM++ OpenCL version (opencl_nvidia_101)	poempp_2k39_d4_1420715574_193293007_0	00:00:44 (00:00:33)	2,0	06:31:33	0,5C + 0,5NV (d1)	Running	Gentoo-10	

con
<app_config>
<app>
<name>poemcl</name>
<max_concurrent>4</max_concurrent>
<gpu_versions>
<gpu_usage>0.5</gpu_usage>
<cpu_usage>0.5</cpu_usage>
</gpu_versions>
</app>
</app_config>

anche se mi sembra che la seconda WU di ogi GPU sia un pelino più lenta della sua controparte...probbilmente non c'è un ottimo balance tra le risorse... m è sepre un buon risultato

:asd:
Inviato: 08/01/2015 18:06 da boboviz #112246
Avatar di boboviz
E' uscita, sul sito di test, sia la versione nuova per cpu che per gpu (la 2.16)
Gli admin chiedono:

We'd especially like to test parallel runs of the GPU application. If you configured your client to run multiple jobs on a single card, or if you have multiple GPUs, we'd highly appreciate your participation.


Saba, Gatto, dove siete??
Inviato: 17/12/2014 17:06 da Rick! #111650
Avatar di Rick!
boboviz ha scritto:

Rick! ha scritto:

Provato a riservare 1 core CPU per ogni task? E' passato tanto tempo, ma mi sembra che aiutasse.


Come sarebbero i parametri?
Io comunque son tornato a
<gpu_usage>1</gpu_usage>
<cpu_usage>1</cpu_usage>

Mi sembra di si, e c'era un parametro anche per limitare le WU elaborate per progetto sempre nel cc_config, credo "maxconcurrent". Magari aiuta evitando che altri prj impegnino la cpu dedicata alla gpu proprio sul più bello.
Inviato: 17/12/2014 10:31 da boboviz #111632
Avatar di boboviz
Rick! ha scritto:

Provato a riservare 1 core CPU per ogni task? E' passato tanto tempo, ma mi sembra che aiutasse.


Come sarebbero i parametri?
Io comunque son tornato a
<gpu_usage>1</gpu_usage>
<cpu_usage>1</cpu_usage>
Inviato: 17/12/2014 08:54 da Rick! #111629
Avatar di Rick!
boboviz ha scritto:

Mettendo 0.5 in entrambi i parametri son riuscito a caricare 2 wu gpu su un core cpu
Il carico gpu è passato dal 89% al 98% e una delle due wu è molto più lenta dell'altra.
Penso la mia gpu sia sottodimensionata..... :muro:

Provato a riservare 1 core CPU per ogni task? E' passato tanto tempo, ma mi sembra che aiutasse.
Inviato: 17/12/2014 08:40 da boboviz #111628
Avatar di boboviz
Ieri sera hanno aggiornato ancora l'applicativo, adesso siamo alla versione 2.15
Accattatevillo!
Inviato: 16/12/2014 22:15 da boboviz #111618
Avatar di boboviz
Mettendo 0.5 in entrambi i parametri son riuscito a caricare 2 wu gpu su un core cpu
Il carico gpu è passato dal 89% al 98% e una delle due wu è molto più lenta dell'altra.
Penso la mia gpu sia sottodimensionata..... :muro:
Inviato: 15/12/2014 22:38 da sabayonino #111554
Avatar di sabayonino
boboviz ha scritto:

sabayonino ha scritto:

quale seconda parte ? :confuso:


Non pensarci
Adesso mi dice 1 cpu+0.5 gpu, quindi sembra corretto.
Solo che non mi carica la seconda wu gpu.
Mi dice sempre "Got 0 new task".
Che sia perchè si rende conto che la mia gpu non supporterebbe due 2 wu gpu in contemporanea?


a me con WU multiple mi fa andare solo la seconda GPU su tutte le configurazioni. anche se imposto 8 WU

boinc.fzk.de/poem/forum_thread.php?id=1097&postid=9983
Inviato: 15/12/2014 22:37 da sabayonino #111553
Avatar di sabayonino
boboviz ha scritto:

sabayonino ha scritto:

quale seconda parte ? :confuso:


Non pensarci
Adesso mi dice 1 cpu+0.5 gpu, quindi sembra corretto.
Solo che non mi carica la seconda wu gpu.
Mi dice sempre "Got 0 new task".
Che sia perchè si rende conto che la mia gpu non supporterebbe due 2 wu gpu in contemporanea?


a me con WU multiple mi fa andare solo la seconda GPU su tutte le configurazioni. anche se imposto 8 WU

boinc.fzk.de/poem/forum_thread.php?id=1097&postid=9983

Per commentare questo post nel forum devi effettuare il login

Articoli

Written on 11/02/2019, 11:13 by boboviz
boinc-workshop-2019Anche quest'anno si terrà il Boinc Workshop, dal 9 al 12 Luglio a Chicago. La partecipazione è libera e gratuita.

Ultime dal Blog

Written on 16/09/2019, 09:51 by boboviz
ci-vuole-un-fisico-bestiale-per-andare-al-cernCome alcuni di voi sapranno, periodicamente, il CERN apre i suoi portoni alla visita di chi vuole andarci e la cosa viene chiamata OpenDays. Questa volta...